Problemi avvio linuxcnc

Sezione dedicata a Linuxcnc
redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Problemi avvio linuxcnc

Messaggioda redscorpion_m » martedì 11 luglio 2017, 21:53

Buonasera a tutti; sono un nuovo utilizzatore di linuxcnc (o almeno spero di esserlo in futuro) ma sto riscontrando un problema. Ho installato la iso di ubuntu con precaricato linuxcnc ed effettuato il setup della scheda e dei motori. Creato il profilo clicco su di esso per aprire il programma ma come appare linuxcnc si blocca; rimane attivo solo il mouse e senza alcuna possibilità di chiudere linuxcnc o ubuntu.
Mi potreste dare qualche consiglio?
Ringrazio anticipatamente.

eBay

eBay annunci

da eBay » venerdì 21 luglio 2017, 1:43


Alex_live
God
God
Messaggi: 4571
Iscritto il: giovedì 30 luglio 2015, 11:06
Località: Milano

Re: Problemi avvio linuxcnc

Messaggioda Alex_live » mercoledì 12 luglio 2017, 8:57

Prova ad avviare il programma da shell ti segnala se ci sono errori/mancanze di file.

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » mercoledì 12 luglio 2017, 12:45

Grazie della risposta Alex...perdonami ma non so come fare...mi indicheresti il procedimento?

Alex_live
God
God
Messaggi: 4571
Iscritto il: giovedì 30 luglio 2015, 11:06
Località: Milano

Re: Problemi avvio linuxcnc

Messaggioda Alex_live » mercoledì 12 luglio 2017, 14:27

Premesso che uso linux ma non ubuntu e nemmeno linuxcnc.
Apri la console o shell o terminale (non so come la chiama ubuntu).
Da tastiera digita il nome del programma che vuoi avviare.
Per velocizzare linserimento del nome del programma puoi utilizzare il tasto TAB per l'auto completamento del nome del programma.
ESEMPIO:
Se il programma si chiama linuxcnc se scrivi la lettera "l" e premi TAB appaiono tutti i possibili programmi avviabili che iniziano con l.
Se suno troppi aggiungi la seconda lettera "i" e premi ancora TAB e cosi di seguito.
Se non visualizzi "linuxcnc" perchè il programma non esiste oppure si chiama "Linuxcnc". Devi allora partire con una "L" maiuscola ed utilizzare sempre il tasto TAB.
Se ci sono degli errori vengono visualizzati in console.

ATTENZIONE non so se lo sai ma linux fa differenza tra maiuscole e minuscole.

Guarda questo video dal minuto 6:50
https://www.youtube.com/watch?v=g2aJAJvuxFw

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » mercoledì 12 luglio 2017, 17:27

Grazie mille Alex...provo subito...

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » mercoledì 12 luglio 2017, 20:49

provato....ma senza risultati positivi..si avvia la schermata di selezione del profilo e dopo l'ok parte linuxcnc e si blocca. da terminale/shell non compaiono errori ne diciture. allego screenshot della shell e della prima schermata.
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.

Alex_live
God
God
Messaggi: 4571
Iscritto il: giovedì 30 luglio 2015, 11:06
Località: Milano

Re: Problemi avvio linuxcnc

Messaggioda Alex_live » giovedì 13 luglio 2017, 9:43

Devi impostare i parametri della tua macchina.
Se premi il tasto ok non passa alla schermata successiva?
Stasera non penso di riuscirci ma tra qualche giorno vedo di provare una live di linuxcmc per aiutarti meglio.

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » giovedì 13 luglio 2017, 20:30

Se premo ok passa al caricamento di linuxcnc..apre la videata del programma e si blocca. La freccia del mouse diventa nera da bianca, posso scorrerla su tutto lo schermo ma rimane tutto bloccato. Devo spegnere il pc "brutalmente" per riprendere il controllo.

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » giovedì 13 luglio 2017, 20:32

I parametri li ho configurati...in ogni caso e su qualsiasi profilo standard e precaricati si blocca.

billielliot
Senior
Senior
Messaggi: 1375
Iscritto il: martedì 16 ottobre 2007, 22:23
Località: Trezzo sull'Adda

Re: Problemi avvio linuxcnc

Messaggioda billielliot » giovedì 13 luglio 2017, 21:11

Ciao,

quale computer usi? (tipo di processore, quanta memoria, scheda video, scheda madre, 32/64 bit etc...)

Cosa ti restituisce il latency test? (vedi ultima immagine di questo messaggio).

Ciao :-)

Mauro
Amat victoria curam

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » giovedì 13 luglio 2017, 22:47

Il latency test mi da come servo 1.0ms max jitter 15799ns e come base 25microsecondi 19485ns.....più o meno dava sempre questi valori...una volta mi sono comparsi dei valori enormi tipo 7milioni sul servo e 3milioni sul base...il pc è un vecchio athlon da 1.67Ghz con 1.50GB di ram. La scheda video è una rage fury pro 2000 su scheda madre qdi k7v600...mi pare sia a 32bit...

billielliot
Senior
Senior
Messaggi: 1375
Iscritto il: martedì 16 ottobre 2007, 22:23
Località: Trezzo sull'Adda

Re: Problemi avvio linuxcnc

Messaggioda billielliot » venerdì 14 luglio 2017, 5:05

I valori del latency test sembrano buoni. Do' per scontato che tu abbia eseguito il test caricando il piu' possibile il processore. In caso contrario il test non e' significativo.

Prova a togliere il mezzo giga di RAM cosi' da rimanere con un solo banco da 1GB in un solo slot.

Prova a disabilitare la scheda audio dal BIOS.

Cambia scheda video (per mia esperienza, con le ATI non sono mai riuscito a lavorare).

Non mi viene in mente altro.

Ciao :-)

Mauro
Amat victoria curam

redscorpion_m
Newbie
Newbie
Messaggi: 8
Iscritto il: domenica 1 giugno 2014, 23:53
Località: cossato

Re: Problemi avvio linuxcnc

Messaggioda redscorpion_m » venerdì 14 luglio 2017, 10:31

Grazie mille Mauro, provo a vedere il tutto.
Fabio


Torna a “Linuxcnc”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite