Problemi col IV asse

Sezione dedicata a Mach3
shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » venerdì 3 novembre 2017, 16:32

Una prova che ho già fatto è quella di invertire i pin 2-3 dell'asse X con i pin 8-9 dell'asse A.
In questo modo l'asse A gira, ma l'asse X no. quindi 8_9 non sarebbero i pin corretti (ma non ne ho altri a disposizione), oppure semplicemente non sono controllati da Mach3 (scheda parallela ?)
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)

eBay

eBay annunci

da eBay » sabato 20 gennaio 2018, 0:03


shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » venerdì 3 novembre 2017, 16:35

Proverò anche a controllare le tensioni presenti ai pin 8-9.
I l guaio è che non ho il laboratorio vicino e all'interno non ho rete internet.
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)

Avatar utente
scj
Moderator
Moderator
Messaggi: 2897
Iscritto il: sabato 25 novembre 2006, 22:31
Località: Prov UD, prov TV

Re: Problemi col IV asse

Messaggioda scj » venerdì 3 novembre 2017, 16:44

Vai a ritroso e cerca di capire quali sono i pin che dalla breackoutboard vanno al drive.
Se non sono l'8 e il 9 (o se lo sono ma sono invertiti) non funzionerà mai.
Il fatto che con 2 e 3 va significa che o hai settaggi sbagliati su mach3 oppure un problema su quei pin. Non è che c'è poi tanto da controllare
Nell'ordine si conserva, nel disordine si crea.
Simone

https://www.youtube.com/channel/UCBPtFN ... subscriber

shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » venerdì 3 novembre 2017, 16:58

Ok
controllerò la porta parallela lato PC, perchè come ho già detto la BB è nuova.
Quanto al settaggio di Mach, non saprei dove correggere, non ultimo motivo perchè non lo conosco abbastanza approfonditamente, avendolo visto per la prima volta pochi giorni fa.
Ti ringrazio
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)

Avatar utente
scj
Moderator
Moderator
Messaggi: 2897
Iscritto il: sabato 25 novembre 2006, 22:31
Località: Prov UD, prov TV

Re: Problemi col IV asse

Messaggioda scj » venerdì 3 novembre 2017, 17:06

Vai nella sezione download e scaricati il manuale in italiano di mach3 (se non l'hai già fatto)
Le impostazioni di mach per quanto riguarda i pin in uscita che controllano i motori ce le hai qua.

Va da se che se il drive del quarto asse non è collegato ai pin 8 e 9 o cerchi di capire quali sono i pin che lo collegano alla bboard o non ne vieni fuori
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
Nell'ordine si conserva, nel disordine si crea.
Simone

https://www.youtube.com/channel/UCBPtFN ... subscriber

shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » venerdì 3 novembre 2017, 20:45

Ho provato tutte le tensioni sulla parallela lato PC:
Drive sono tutti a 3,350 V circa (oscilla un pò)
Dir sono all'incirca sui 50 mV, tranne che per l'asse Z che si trova anch'esso a 3,350 V, avendolo invertito sulle impostazioni di Mach3.
Ho controllato il cavo parallelo ed è a posto.
Ho controllato la BB e curiosamente, sotto i connettori degli assi, riporta stampata la seguente sequenza: A-Z-Y-X, vista dal lato connettori.
Questa non corrisponde a quella che avevo impostato io, e neppure alla sequenza consigliata nel manuale di Damogran-Labs.
Mah!
Ho ricablato le uscite dalla BB ai driver secondo quanto stampato sulla BB, ma non riesco a far andare 2 motori.
Domani ci riproverò.
Grazie per la pazienza, so che l'argomento non è così eccitante.
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)

Avatar utente
scj
Moderator
Moderator
Messaggi: 2897
Iscritto il: sabato 25 novembre 2006, 22:31
Località: Prov UD, prov TV

Re: Problemi col IV asse

Messaggioda scj » venerdì 3 novembre 2017, 21:08

3.35v ci può stare. Non sono il massimo ma se la bboard è bufferizzata dovrebbe rialzarli a 5 volt verso i drivers.

Per me sbagli approccio. Non è che le cose sono casuali e spostando i cavi dei segnali senza una logica la cosa possa funzionare.
Rimetti tutto come prima almeno lavoriamo solo sul quarto asse .
Quello che è stampato sulla bboard non ti interessa a meno che non sia stampata la sequenza dei pin: P1,P2, ecc ecc.

Se leggevi con attenzione quanto scritto prima la tensione di pin di dir deve settarsi a 0V o 5V (nel tuo caso a questo punto 3.35v) in base alla direzione che impartisci al motore
Ad esempio per l'asse X il pin di dir (il pin 3) deve essere a 5v (3.35v) se premi la freccia da una parte e 0V (0.05V) se premi la freccia dal lato opposto.

Infine i valori impostati su config/port and pins/motor output li puoi cambiare a tuo totale piacimento, basta che corrispondano all'effettivo collegamento tra pin e drivers.
Nell'ordine si conserva, nel disordine si crea.
Simone

https://www.youtube.com/channel/UCBPtFN ... subscriber

shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » venerdì 3 novembre 2017, 21:34

Ok, purtroppo la logica, a volte, lascia il posto ad altro.
Domani riprovo.
Grazie
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)

shardana
Newbie
Newbie
Messaggi: 18
Iscritto il: martedì 5 aprile 2016, 19:30
Località: Sardegna

Re: Problemi col IV asse

Messaggioda shardana » sabato 4 novembre 2017, 13:59

Risolto!!!
Adesso tutto funziona.
Alla fine era solo questione di avere un pò di tempo per fare qualche prova.
Adesso direi che funziona tutto bene. Ho tarato le velocità che mi parevano più consone ad ogni asse, tenendo A molto, molto lento.
complessivamente sono soddisfatto della realizzazione.
Un grazie a SCJ per la sua pazienza.
"Non si vede bene che con gli occhi; il gradino è invisibile al cuore" (Il piccolo Cinico)


Torna a “Mach3”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite