1° fresa cnc Problemi con motori Sanyo Denki

Sezione dedicata alla tua CNC: Costruzione, descrizione, foto, accorgimenti ed errori di progettazione.

Moderatori: kalytom, walgri

darthsidious
Newbie
Newbie
Messaggi: 5
Iscritto il: sabato 19 novembre 2016, 17:40

1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda darthsidious » domenica 11 giugno 2017, 19:53

Salve
Ho terminato di realizzare la mia prima cnc.
Non avendo alle spalle studi di meccanica ed elettronica grazie a consigli in giro per la rete, sono ugualmente riuscito a realizzarla.
Ho utilizzato come progetto base la Shapeoko realizzando 3 lastre in alluminio dove ho montato guide in alluminio acquistate presso Openbuilds, Trasmissione a cinghia (2 per l'asse Y, 1 per X e 1 per Z), 4 motori nema 23 Sanyo Denki unipolari (ho letteralmente cannibalizzato una fotocopiatrice CANON IR in disuso):
Asse Y 2 stepper 103H7124
Asse X 1 stepper 103H7126 0649
Asse Z 1 stepper 103H7123 0760
Per l'elettronica ho acquistato per pochi soldi una scheda TB6560 Creostamp a 5 assi con Mach3
Alimentatore 24V 10A
Tutto sembra funzionare discretamente, ho anche fresato piccole scritte su compensato non ostante qualche piccola perdita di passo sugli assi X ed Y.

Il problema che ho riscontrato è il seguente:
Quando faccio muovere gli assi con le frecce i motori, durante il movimento hanno delle minuscole accelerazioni. La rotazione non risulta fluida come ho potuto notare da molti video su youtube.

Qualcuno ha avuto problemi simili? Consigli su come migliorare la macchina?
Ringrazio per le risposte.

eBay

eBay annunci

da eBay » mercoledì 20 settembre 2017, 19:25


salvatore993
Senior
Senior
Messaggi: 1643
Iscritto il: giovedì 23 novembre 2006, 8:04
Località: Napoli-Tenerife
Contatta:

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda salvatore993 » lunedì 12 giugno 2017, 7:45

monto questi motori da sempre, se l'elettronica è in grado di pilotarli degnamente sono ottimi, danno il meglio di se sopra i 50volt di alimentazione, a patto che i driver li supportino. posta i settaggi, e la configurazione dell'elettronica, e perché no anche qualche foto della macchina, ci saranno più dati per aiutarti.

darthsidious
Newbie
Newbie
Messaggi: 5
Iscritto il: sabato 19 novembre 2016, 17:40

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda darthsidious » martedì 13 giugno 2017, 16:04

Grazie per la risposta.
Come immaginavo il problema ricadrebbe nella scheda elettronica TB6560 cinese. Ho già letto in tanti forum essere poco affidabile. Data la mia scarsa conoscenza in materia, ho preferito andare al risparmio e intanto "farmi le ossa".
Il settaggio è quello canonico (alimentatore 24V 10A, microstepping 1/16, Corrente fase motori 75%).
Che "tipologia" di elettronica (driver ecc..) mi consigli pilotare al meglio questi motori?

darthsidious
Newbie
Newbie
Messaggi: 5
Iscritto il: sabato 19 novembre 2016, 17:40

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda darthsidious » martedì 13 giugno 2017, 16:08

Ecco la mia CNC (non definitiva)
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.

salvatore993
Senior
Senior
Messaggi: 1643
Iscritto il: giovedì 23 novembre 2006, 8:04
Località: Napoli-Tenerife
Contatta:

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda salvatore993 » mercoledì 14 giugno 2017, 7:06

se metti un elettronica degna come dei driver RTA che sono la morte loro, un alimentatore sopra i 50 volt ed un qualsiasi controllo usb ti ritrovi un elettronica sproporzionata ma comunque validissima, se vuoi farti le ossa credo che ti convenga comprare motori tipo "wantai" (cinesi semi-buoni) da 2 ampere e la muovi senza problemi. la meccanica non sembra esosa. scegli dei motori che abbiano una curva che ti permetta di avere velocità accettabili a quelle tensioni. alza un po la tensione dell'alimentatore la scheda tb dovrebbe permettertelo, se non sbaglio i driver dovrebbero sopportare una trentina di volt e passa, 32/36.

darthsidious
Newbie
Newbie
Messaggi: 5
Iscritto il: sabato 19 novembre 2016, 17:40

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda darthsidious » lunedì 19 giugno 2017, 15:30

Grazie per i preziosi :P consigli

Avatar utente
scj
Senior
Senior
Messaggi: 2372
Iscritto il: sabato 25 novembre 2006, 22:31
Località: Prov UD, prov TV
Contatta:

Re: 1° fresa cnc Problemi con motori Sanyo Denki

Messaggioda scj » martedì 20 giugno 2017, 6:15

per quanto elementari i tb6560 non sono poi così male, naturalmente limitatamente a quello che possono dare.
Se non hai impuntamenti meccanici dicci che soft usi, come è impostato, che settaggio hai.
Potrebbe essere semplicemente da cambiare il parametro "Step Low Active" (se hai mach3) per vedere se girano più fuidi.

E comunque tra i tb6560 e gli RTA ci sono migliaia di drive dal prezzo intermedio con prestazioni sufficienti/buone per un hobbista alle prime armi.
Nell'ordine si conserva, nel disordine si crea.
Simone


Torna a “La mia CNC”

Chi c’è in linea

Visitano il forum: daniele86, FIREF00X, kylotron e 1 ospite