Connessione driver e segnali comando

Sezione dedicata all'elettronica in generale.
Rispondi
camietto
Junior
Junior
Messaggi: 61
Iscritto il: venerdì 4 marzo 2011, 13:49
Località: Treviso

Connessione driver e segnali comando

Messaggio da camietto » martedì 13 ottobre 2020, 9:52

Ciao a tutti,
Sto asemblando una nuova cnc e sono mesi che incorro in problemi continui che però un passo alla volta sono riuscito a risolvere.
Oggi mi trovo costretto a chiedere il vostro aiuto...vi spiego meglio..

Il mio intento era di usare una Ess smoothstepper con la breakoutboard di cnc technics e comandare dei driver AM882.

Come dalle foto la break out board esce con un treno di impulsi che miu sembra adeguato in voltaggio e modulazione , il segnale di direzione come l'enable arrivano corretti qualcosa meno di 5v .
Ho voluto provare con un driver che avevo in casa 2m542 ma non da segno di vita .
Ho controllato gli avvolgimenti e collegamenti del motore con il tester ma dovrebbe essere tutto ok.
Ho provato con una scheda parallela già con driver incorporati e il motore gira.
Ho già cambiato due volte la breakoutboard e dopo ripetuti controlli mi assicurano lavorare bene, in effetti i segnali in uscita misurati mi sembrano più che buoni.

Cosa posso ancora verificare? tks
Non hai i permessi necessari per visualizzare i file e le foto allegati in questo messaggio. Per visualizzare tali file devi registrarti ed effettuare il Login

camietto
Junior
Junior
Messaggi: 61
Iscritto il: venerdì 4 marzo 2011, 13:49
Località: Treviso

Re: Connessione driver e segnali comando

Messaggio da camietto » martedì 13 ottobre 2020, 9:55

Le misure sono fatte sui morsetti del driver.
Ho provato anche con questo m542 perchè non ho ancora il cavo per programmare am882 e ho pensato che forse fosse per quello ma nulla

camietto
Junior
Junior
Messaggi: 61
Iscritto il: venerdì 4 marzo 2011, 13:49
Località: Treviso

Re: Connessione driver e segnali comando

Messaggio da camietto » giovedì 15 ottobre 2020, 9:30

Nessuno ha qualche idea? almeno su cosa ricontrollore?

Avatar utente
kalytom
Administrator
Administrator
Messaggi: 36377
Iscritto il: lunedì 13 novembre 2006, 9:17
Località: Poggiomarino (Na)
Contatta:

Re: Connessione driver e segnali comando

Messaggio da kalytom » giovedì 15 ottobre 2020, 12:50

quando alimenti il driver il motore va in tiro o resta libero ? ti segnala luce verde o rossa ?
Immagine

camietto
Junior
Junior
Messaggi: 61
Iscritto il: venerdì 4 marzo 2011, 13:49
Località: Treviso

Re: Connessione driver e segnali comando

Messaggio da camietto » lunedì 26 ottobre 2020, 13:50

Eccomi, grazie, periodo stranissimo, mi tocca girare come una trottola e fatico a trovare il tempo per le passioni, ma cmq eccomi qui...

ho fatto le prove che mi hai chiesto... le luci del driver sono verdi, lampeggianti senza abilitazione e fisse con.
I motori vanno in tiro e giocando con configurazioni di step corrente ecc a volte fanno un accenno a muoversi e poi vanno in errore del drive.
Tra poco dovrebbero arrivare anche i cavi per programmare i driver.
Cosa strana però anche con il driver non programmabile software non cè segno di vita...

Avatar utente
danieleee
Senior
Senior
Messaggi: 2892
Iscritto il: lunedì 8 marzo 2010, 22:38
Località: Borgo Vercelli

Re: Connessione driver e segnali comando

Messaggio da danieleee » lunedì 26 ottobre 2020, 14:48

Domanda banale ma necessaria...
Hai configurato la rete Network per la SSE?
Il plugin??
Mach3 o Mach4??

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1361
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: Connessione driver e segnali comando

Messaggio da hellfire39 » lunedì 26 ottobre 2020, 15:10

Controlla che l'Enable abbia la giusta polarità, di solito lavora attivo basso (enable = 0V).
Non interpreto bene il treno di impulsi: se stessi comandando un movimento continuo, gli impulsi dovrebbero essere equidistanziati.
Non capisco come mai ci sono quei buchi ogni tre impulsi.

Avatar utente
turbina
God
God
Messaggi: 5142
Iscritto il: domenica 19 novembre 2006, 14:34
Località: Paese TREVISO
Contatta:

Re: Connessione driver e segnali comando

Messaggio da turbina » martedì 27 ottobre 2020, 9:12

Se guardi bene e' impostato a 5mS per divisione , quindi ad occhio sta andando a 250- 300 step/sec una velocità talmente bassa che non necessita nemmeno della rampa, quindi le pause più lunghe possono essere presenti senza pericolo di stallo
Fresa CNC ISEL Gantry027, Tornio CNC DM3000, 3DP PrusaI3.

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1361
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: Connessione driver e segnali comando

Messaggio da hellfire39 » martedì 27 ottobre 2020, 14:14

È vero, però è sempre un comportamento anomalo, che non mi spiego.
L'importante è controllare la polarità dell'enable

Avatar utente
danieleee
Senior
Senior
Messaggi: 2892
Iscritto il: lunedì 8 marzo 2010, 22:38
Località: Borgo Vercelli

Re: Connessione driver e segnali comando

Messaggio da danieleee » martedì 27 ottobre 2020, 14:48

Secondo me non ha impostato correttamente il software...
Con la SSE bisogna impostare le varie porte...
Ricordo anche che vi erano dei ponticelli da inserire o meno, a seconda delle configurazioni...
@caminetto...
Prima controlla tali ponticelli...
Poi fai un test di ping...
Poi le varie porte e così via...

Rispondi

Torna a “Elettronica”