Motore CC e Pic Micro

Sezione dedicata all'elettronica in generale.
Rispondi
Avatar utente
Vecchietto67
Member
Member
Messaggi: 516
Iscritto il: lunedì 9 ottobre 2017, 7:28
Località: Bologna

Re: Motore CC e Pic Micro

Messaggio da Vecchietto67 » domenica 3 aprile 2022, 20:47

No sembra che il programma si blocchi in modo random. Comunque domani metto in pratica i tuoi suggerimenti e poi posto i risultati
Non sono un genio ma voglio farvi credere che lo sono .........

Avatar utente
Vecchietto67
Member
Member
Messaggi: 516
Iscritto il: lunedì 9 ottobre 2017, 7:28
Località: Bologna

Re: Motore CC e Pic Micro

Messaggio da Vecchietto67 » venerdì 8 aprile 2022, 10:00

E anche questa volta hellfire ha fatto GOAL =D>
Due problemi causavano il reset del micro.

Mi sono dimenticato di mettere il condensatore immediatamente vicino ai pin di alimentazione del micro. Non è una dimenticanza grave ma aiuta a creare problemi.

Avevo alimentato i led del fotoaccoppiatore con i +5V che poi alimentavano anche il micro. Anche se non ho un riscontro strumentale sicuramente i disturbi generati dal motore entravano nel micro attraverso l'alimentazione.
Ho separato le alimentazioni utilizzando i +12V del motore per alimentare anche i led del fotoaccoppiatore e magicamente i problemi sono scomparsi. Ho tolto anche la ferrite e ho avvolto assieme i cavi del motore e quelli degli ingressi del fotoaccoppiatore per aumentare la possibilità di propagazione dei disturbi. Per adesso tutto OK.
Spero sia la soluzione definitiva
Non sono un genio ma voglio farvi credere che lo sono .........

Rispondi

Torna a “Elettronica”