Laser cinese 5w non funziona più???

Moderatore: kalytom

Rispondi
Facatoan
Newbie
Newbie
Messaggi: 5
Iscritto il: giovedì 21 novembre 2019, 16:09

Laser cinese 5w non funziona più???

Messaggio da Facatoan » venerdì 22 novembre 2019, 11:07

Salve gente, spero prorpio di trovare qualcuno con le competenze ge che mi possa aiutare...
Da qualche anno utilizzavo una piccolo engraver laser (Eleksmaker A3 pro con laser da 2,5w). Poichè volevo aumentare un poco la potenza di "fuoco" ho acquistato da bangood un altro modulo laser da 5w sostituendolo all'originale. Per un po' è andato tutto bene poi all'improvviso è successa una cosa strana: il laser si accendeva regolarmente per garantire la corretta messa a fuoco ma poi quando partiva il codice GRBL per l'incisione, restava nella modalità "safe" senza erogare luce alla potenza desiderata e impostata: in sostanza non bruciava più nulla! Premetto che non avevo modificato alcunchè!!! Non essendo assolutamente sperto e pensando che il laser fosse andato ho rimontato il vecchio modulo da 2,5w ma pure quello presentava lo stesso comportamneto anomalo! Mi sono detto: vabbè, forse è andata la scheda che controlla il tutto...ed ho acquistato una nuova scheda dal sito Eleksmaker (una EleksManaSE V3.2 2). Anche in questo caso però niente da fare!!!!
Ovviamente nessuno dei produttori cinsei da me contattati si degna di rispondere e di fornirmi una spiegazione.
In conclusione adesso ho due moduli laser che si accendono entrambi ma non bruciano e due schede Mana SE senza però che niente funzioni..
Potete aiutarmi a chiarire il mistero? cosa può essere successo improvvisamente e soprattutto, come posso risolvere la cosa?
AIUTOOOOOOOOOO

ECELO
Newbie
Newbie
Messaggi: 2
Iscritto il: martedì 3 dicembre 2019, 12:57

Re: Laser cinese 5w non funziona più???

Messaggio da ECELO » martedì 3 dicembre 2019, 13:13

Ciao, hai provato a fare il reflash dell'Arduino nano con il firmware originale di Eleksmana? Ho avuto un problema simile, ma ho risolto facendo un reflash dell'aurduino alla versione base e resettando tutti i parametri di grbl.

Facatoan
Newbie
Newbie
Messaggi: 5
Iscritto il: giovedì 21 novembre 2019, 16:09

Re: Laser cinese 5w non funziona più???

Messaggio da Facatoan » mercoledì 4 dicembre 2019, 14:07

Ciao e grazie della risposta.
Se con arduino nano intendi la scheda Elksmana originali sì, ho fatto più volte il reflash ma senza successo..
Altrimenti non ho capito cosa volevi dire, perchè non c'è alcun modulo arduino attaccato alla mia macchina.

Avatar utente
tittopower
Member
Member
Messaggi: 292
Iscritto il: lunedì 1 novembre 2010, 23:54
Località: Cattolica (RN)
Contatta:

Re: Laser cinese 5w non funziona più???

Messaggio da tittopower » mercoledì 4 dicembre 2019, 18:20

Per quanto riguarda il reflash mi capitò una cosa simile con una cnc-grbl che non si comportava come doveva, finchè continuavo a riflasshare non andava a posto niente, poi ho trovato un codice .ino che faceva un vero reset del arduino e una volta ricaricato il grbl tutto OK, quindi ti suggerirei di provare il reset completo di arduino.
Per testare se il laser funziona come deve, individuato il suo pin TTL inviagli a seconda del laser, o un GND o 5 volt, in una delle 2 condizioni si deve accendere alla massima potenza.
MF30 - 1991 Inverter & Ceriani 203 Norton - 1996 Inverter & XJ25 CNC - 2013 & Prusa I4 2016 & Little Laser 2019 & CNC-PCB 2019 - http://www.tittopower.it/

Facatoan
Newbie
Newbie
Messaggi: 5
Iscritto il: giovedì 21 novembre 2019, 16:09

Re: Laser cinese 5w non funziona più???

Messaggio da Facatoan » giovedì 5 dicembre 2019, 11:42

Ne approfitto della tua gentilezza...
questo è il laser:
Laser.jpg
Mi puoi spiegare come fare i collegamenti che suggerisci? Sono un neofita e non capisco cosa vuoi dire con inviargli o un GND o volt...
Tieni conto che ho alimentato direttamente il laser senza passare dalla scheda EleksMana, utilizzando la schedina di alimentazione che è arrivata assieme, ma il risultato è il medesimo, si accende ma non alla massima potenza...
Comunque proverò innanzitutto a fare il reset da codice e poi vediamo.
Grazie veramente tanto della pazienza!
Non hai i permessi necessari per visualizzare i file e le foto allegati in questo messaggio. Per visualizzare tali file devi registrarti ed effettuare il Login

Avatar utente
hellfire39
Member
Member
Messaggi: 493
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: Laser cinese 5w non funziona più???

Messaggio da hellfire39 » giovedì 5 dicembre 2019, 12:07

@tittopower
che significa "fare un vero reset di arduino"?

Stai parlando della eeprom?

Avatar utente
tittopower
Member
Member
Messaggi: 292
Iscritto il: lunedì 1 novembre 2010, 23:54
Località: Cattolica (RN)
Contatta:

Re: Laser cinese 5w non funziona più???

Messaggio da tittopower » giovedì 5 dicembre 2019, 15:44

@Facatoan:
Alimenta il laser normalmente con la tensione prevista, togli dal connettore il filo PWM e a quel pin dovrai provare a dare o GND ovvero massa negativo del circuito del nano oppure un +5V sempre del nano, se tu avessi una resistenza da qualche centinaio di ohm da porre in serie sarebbe un bene.

@hellfire39:
Ho constatato che quando ricaricavo un grbl come appena scaricato ovvero non configurato secondo le mie esigenze, quando andavo ad aprire un programma di configurazione mi ritrovavo settati gli stessi parametri che in realtà dovevano sparire. Ho trovato un file che permette un reset della eeprom che ho ritrovato (usato su arduino UNO):

#include <EEPROM.h>
void setup()
{
// write a 0 to all 512 bytes of the EEPROM
for (int i = 0; i < 512; i++)
EEPROM.write(i, 0);

// turn the LED on when we’re done
digitalWrite(13, HIGH);
}

void loop()
{
}

Una volta caricato questo programma e di seguito un grbl vergine in effetti ho trovato i parametri standard grbl.

All'interno del IDE dal menù FILE--> ESEMPI-->EEPROM ho poi trovato la presenza di un eeprom_clear.ino che probabilmente fa la stessa cosa:

/*
* EEPROM Clear
*
* Sets all of the bytes of the EEPROM to 0.
* Please see eeprom_iteration for a more in depth
* look at how to traverse the EEPROM.
*
* This example code is in the public domain.
*/

#include <EEPROM.h>

void setup() {
// initialize the LED pin as an output.
pinMode(13, OUTPUT);

/***
Iterate through each byte of the EEPROM storage.

Larger AVR processors have larger EEPROM sizes, E.g:
- Arduno Duemilanove: 512b EEPROM storage.
- Arduino Uno: 1kb EEPROM storage.
- Arduino Mega: 4kb EEPROM storage.

Rather than hard-coding the length, you should use the pre-provided length function.
This will make your code portable to all AVR processors.
***/

for (int i = 0 ; i < EEPROM.length() ; i++) {
EEPROM.write(i, 0);
}

// turn the LED on when we're done
digitalWrite(13, HIGH);
}

void loop() {
/** Empty loop. **/
}

Il primo sketch nel mio caso ha funzionato per quello che volevo, quello degli esempi del IDE non l'ho provato.
MF30 - 1991 Inverter & Ceriani 203 Norton - 1996 Inverter & XJ25 CNC - 2013 & Prusa I4 2016 & Little Laser 2019 & CNC-PCB 2019 - http://www.tittopower.it/

Avatar utente
hellfire39
Member
Member
Messaggi: 493
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: Laser cinese 5w non funziona più???

Messaggio da hellfire39 » giovedì 5 dicembre 2019, 15:55

ok, chiaro.
Grazie

Facatoan
Newbie
Newbie
Messaggi: 5
Iscritto il: giovedì 21 novembre 2019, 16:09

Re: Laser cinese 5w non funziona più???

Messaggio da Facatoan » lunedì 9 dicembre 2019, 14:23

Siccome ho acquistato con il laser anche una schedina di alimentazione a parte (come quella in foto), i collegamenti che suggerisci sono questi?
Non hai i permessi necessari per visualizzare i file e le foto allegati in questo messaggio. Per visualizzare tali file devi registrarti ed effettuare il Login

Rispondi

Torna a “Laser CNC”