perdita passi con laser

Sezione dedicata alla tua CNC: Costruzione, descrizione, foto, accorgimenti ed errori di progettazione.
Rispondi
marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

perdita passi con laser

Messaggio da marcy69 » lunedì 14 settembre 2020, 22:09

salve gente,ho aggiunto alla mia cnc autocostruita in legno con fresa 220v un laser 5w,ho iniziato a fare delle prove col laser e foto vettoriali ,stò usando lasergrbl e ho notato perdita di passi sul finire a destra verso il motore con lavorazione in orrizontale,mentre stesso file e stessi parametri in lavorazione in verticale tutto ok.
ps: la fresa è stata tolta quando uso laser
IMG_20200914_215427-min.jpg
IMG_20200914_215442-min.jpg
Non hai i permessi necessari per visualizzare i file e le foto allegati in questo messaggio. Per visualizzare tali file devi registrarti ed effettuare il Login

salvatore993
Senior
Senior
Messaggi: 1901
Iscritto il: giovedì 23 novembre 2006, 8:04
Località: Napoli-Tenerife
Contatta:

Re: perdita passi con laser

Messaggio da salvatore993 » martedì 15 settembre 2020, 8:28

che impostazioni usi, e che macchina hai. ad occhio sembrerebbe che la macchina non riesce a raggiungere in orizzontale (in pratica la direzione del raster in modo laser) le velocità impostate. può capitare se usando gbrl laser, che suppone una macchina a cinghia, lo spari su una macchina che ha le viti.

marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

Re: perdita passi con laser

Messaggio da marcy69 » martedì 15 settembre 2020, 21:41

@salvatore993 perdonami perchè non è da tanto che ho iniziato a conoscere mondo arduino grbl ecc,spiegami cosa vuol dire direzione del raster in modo laser,comunque la cnc è di legno 30x20 con barre da 8 e viti passo 8 su assi x e y,la z vite passo 1 ma nn c'interessa in questo problema,gli step/m li ho provati a 1/4 (100) e a 1/18(400).
ps:stavo pensando di prendere un telaio già pronto 45x45 solo per laser,dicono che è meglio a trascinazione a cinghia,è vero?

salvatore993
Senior
Senior
Messaggi: 1901
Iscritto il: giovedì 23 novembre 2006, 8:04
Località: Napoli-Tenerife
Contatta:

Re: perdita passi con laser

Messaggio da salvatore993 » mercoledì 16 settembre 2020, 8:13

il disegno che hai postato, credo che non venga fatto in modalità vettore, ossia seguendo le linee, ma scorrendo su tutta la linea orizzontale (o verticale è lo stesso) avanti e indietro accendendo il laser dove serve annerire (modalità raster). di solito questo il cam (programmi tipo lasergrbl) , lo imposta ad una velocità che suppone una struttura a cinghie. queste velocità di solito sono troppo alte per le viti anche di buona qualità, con le viti che dici, suppongo siano quelle delle stampanti 3d è impossibile. prova ad eseguire lo stesso disegno ad una velocità massima di 300 mm/min (o 5mm/sec che è lo stesso) e vedi se salta passi.

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1422
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: perdita passi con laser

Messaggio da hellfire39 » mercoledì 16 settembre 2020, 8:47

...1/4 (100) e a 1/18(400)....
C'è un refuso in questa affermazione?

marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

Re: perdita passi con laser

Messaggio da marcy69 » mercoledì 16 settembre 2020, 9:09

.ho sbagliato a scrivere, ..1/4 di passo 100 step/mm oppure ho provato a 1/16 di passo a 400, sono gli step/mm impostati in grbl, non ho capito questi 300/mm dove devo impostarlo, dentro laser grbl?

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1422
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: perdita passi con laser

Messaggio da hellfire39 » mercoledì 16 settembre 2020, 10:39

i 300 mm/min (le unità di misura sono importanti!!!!!, 300mm/min è divero da 300mm/s!!!!!!!!!!!!!!!!)

li dovrai impostarli nel sw che genera il g-code che dai in pasto alla macchina.

marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

Re: perdita passi con laser

Messaggio da marcy69 » mercoledì 16 settembre 2020, 19:36

@helfire39 io stò usando lasergrbl,quindi niente generazione di Gcode,almeno che lo salvi dopo,questi 300/mm dovrei metterli in engravig spedd? lasergrbl su compensato suggerisce 3000

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1422
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: perdita passi con laser

Messaggio da hellfire39 » mercoledì 16 settembre 2020, 20:11

Lasergbrl importa g code e immagini raster. Nel caso di immagini raster, ci pensa lui stesso a creare il gcode.
Hai trovato il parametro giusto, ma fammi una cortesia: utilizza le unità di misura giuste: 300 mm/min.
300/mm non significa un c...avolo.

Forse viene suggerito 3000 mm/Min, ma la tua macchina ci arriva a quella velocità?

marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

Re: perdita passi con laser

Messaggio da marcy69 » mercoledì 16 settembre 2020, 21:34

hellfire39 ha scritto:
mercoledì 16 settembre 2020, 20:11
Forse viene suggerito 3000 mm/Min, ma la tua macchina ci arriva a quella velocità?
e già a questo non ci ero arrivato, al momento sono a 1/16 di passo a 400/mm min assi x e y, quindi mettendo 300/mm min su engraved speed
mi riduce la velocità di 100 e dovrebbe incidere meglio?

Avatar utente
MauPre75
Senior
Senior
Messaggi: 1073
Iscritto il: venerdì 1 dicembre 2017, 14:43
Località: Castelbuono (Pa)

Re: perdita passi con laser

Messaggio da MauPre75 » mercoledì 16 settembre 2020, 23:16

Con 3000mm/min si parla di velocità massima di spostamento (feed rate), non centrano i passi (step/mm) , non fare confusione con i due parametri.
Ti è stato chiesto se la tua macchina con viti riesce a spostarsi ad una velocità di 3000 mm al minuto.

Avatar utente
hellfire39
Senior
Senior
Messaggi: 1422
Iscritto il: domenica 16 dicembre 2012, 9:04
Località: AN

Re: perdita passi con laser

Messaggio da hellfire39 » giovedì 17 settembre 2020, 8:19

@marcy69
STAI CONFONDENDO LE UNITA' DI MISURA!
(Si, lo dico urlando).

Se non capisci le unità di misura continuerai a fare confusione.

300 mm/min è una velocità: indica quandi mm deve fare l'asse in un minuto. E' il valore che devi mettere su engraving speed.

400 passi/mm è un rapporto che infica alla macchina quanti impulsi deve dare al driver per far muovere l'asse di un millimetro.

Sono due cose assolutamente differenti tra loro. Se non capisci questi concetti, è inutile andare avanti.

Cerca ri ripassare questi concetti da prima media e poi risentiamoci!

marcy69
Junior
Junior
Messaggi: 134
Iscritto il: domenica 2 aprile 2017, 23:03

Re: perdita passi con laser

Messaggio da marcy69 » domenica 20 settembre 2020, 22:52

MauPre75 ha scritto:
mercoledì 16 settembre 2020, 23:16
Ti è stato chiesto se la tua macchina con viti riesce a spostarsi ad una velocità di 3000 mm al minuto.
al momento usando il laser e 1/16 di step ho configurato il feddrate a 500.000,quindi il valore massimo che posso mettere su engraved sped è 500 ?se metto di più come dite voi la macchina resta uguale

Avatar utente
MauPre75
Senior
Senior
Messaggi: 1073
Iscritto il: venerdì 1 dicembre 2017, 14:43
Località: Castelbuono (Pa)

Re: perdita passi con laser

Messaggio da MauPre75 » lunedì 21 settembre 2020, 1:07

Se va a 500 non va a 3000, giusto?
No che non sarebbe uguale, sarebbe molto più veloce, ma li può sostenere?
Ripeto che gli step a 1/16 sono un altro argomento.

Paolo Laura
Junior
Junior
Messaggi: 172
Iscritto il: lunedì 4 luglio 2011, 20:34
Località: Sanremo

Re: perdita passi con laser

Messaggio da Paolo Laura » martedì 22 settembre 2020, 16:24

ciao, anchio ho comprato un laserino 5,5W ma non so come connetterlo alla scheda di controllo della cnc ...mi dai 2 dritte? - grazie

Rispondi

Torna a “La mia CNC”